goCASE Administration Guide

Prepared By: Information Technology Service (ITS)
Last Edited: 16/04/2015 DM/ITS/QAT

UNODC
United Nations Office on Drugs and Crime
Table of Contents

1 RESOURCE MANAGEMENT ........................................................................................................... 4
  1.1 CREATE PERSON .................................................................................................................. 6
  1.2 EDIT PERSON ..................................................................................................................... 8
  1.3 CREATE ORGANIZATIONAL GROUP ............................................................................... 9
  1.4 EDIT ORGANIZATIONAL GROUP .................................................................................... 10
  1.5 ADD PERSON TO ORGANIZATIONAL GROUP ............................................................... 11
  1.6 DELETE ORGANIZATIONAL GROUP .............................................................................. 13

2 REFERENCE TABLES .................................................................................................................. 14
  2.1 ADD REFERENCE TABLE OPTIONS ............................................................................... 17
  2.2 EDIT REFERENCE TABLE OPTIONS ............................................................................... 19
  2.3 DELETE REFERENCE TABLE OPTIONS .......................................................................... 19

3 SYSTEM ADMINISTRATION .................................................................................................... 20
  3.1 LOCALIZATION .................................................................................................................. 20
    3.1.1 Create culture ............................................................................................................... 21
    3.1.2 Extract All Translatable Text ..................................................................................... 22
    3.1.3 Translate goCASE ....................................................................................................... 23
  3.2 CASE OBJECTS .................................................................................................................. 24
    3.2.1 Enable / disable object for case type ........................................................................ 25
    3.2.2 Change object icon ..................................................................................................... Error! Bookmark not defined.
    3.2.3 Matching Objects ....................................................................................................... 24
  3.3 SECURITY ............................................................................................................................. 27
    3.3.1 User Maintenance ....................................................................................................... 27
    3.3.2 Role maintenance ....................................................................................................... 30
    3.3.3 Report Maintenance ................................................................................................... 33
    3.3.4 Screen maintenance .................................................................................................. 35
  3.4 SETTINGS ............................................................................................................................. 37
    3.4.1 Application settings .................................................................................................... 37
    3.4.2 Audit ............................................................................................................................ 39
    3.4.3 Custom numbering settings ...................................................................................... 40
    3.4.4 Full-text language settings ....................................................................................... 40 Error! Bookmark not defined.
  3.5 TEMPLATE MAINTENANCE .................................................................................................. 43
    3.5.1 Create Template ......................................................................................................... 43
    3.5.2 Edit Template ............................................................................................................. 44
    3.5.3 Delete Template ......................................................................................................... 44
  3.6 WORKFLOW .......................................................................................................................... 45
    3.6.1 Create Workflow Business Cycle ............................................................................... 45
    3.6.2 Create Regular Flow Transitions ............................................................................... 47
    3.6.3 Create Optional Flow Transitions ............................................................................. 47
    3.6.4 Add Optional Transitions to Regular Transitions ...................................................... 50
    3.6.5 Assign Roles and Users ............................................................................................. 50
    3.6.6 Assign Workflow to Case Type ............................................................................... 51
Foreword

goCASE is UNODC’s software solution for law enforcement agencies, intelligence units and investigative bodies to manage and track the investigation of criminal and other offences. goCASE facilitates the collection and development of intelligence and the investigation and prosecution process that constitutes the front end of most criminal justice systems (CJS). It is a single solution that addresses all requirements needed by intelligence authorities within criminal justice systems either to support analysts in developing inferences and hypotheses and producing strategic or tactical outputs, to support front-line officers and investigators in identifying and reacting to investigative leads or to support prosecutors in handling court cases.
1 Resource Management

The resource management component facilitates the handling of people and groups within goCASE. The organizational structure is defined, and the people/groups in their respective teams are depicted in this hierarchical structure.

**Note:** The access to the case files is managed based on the people and groups defined within the resource management component.

1. Click on “Resource Management” in the toolbar, on the Resource Management link in the Menu panel of the Startup tab or select System Admin ➔ Resource Management from the menu. The resource manager is loaded and displayed.

2. Select the Group tab to load the Group hierarchy.

**Groups:**

The **Group** view consists of **Group Detail**. The details of the group currently selected in the groups list as well as the members of the currently selected group.

**Persons:**

The Person view is displayed below:
**Resource Management**

**Person Details:** The personal data of the person selected in the resource list.

**Group Membership:** A list of groups to which the selected person belongs

**Access Status in goCASE:** The current access status for the selected user.

**Functions:**

The following functions are available:

- **Add a new Person:** Add a new person to goCASE (see section 1.1: [Create a new person](#)).
- **Edit Person:** Modify person details (see section 1.2: [Edit person](#)).
- **Create Group:** Add a new group to the organization’s hierarchy (see section 1.3: [Create an organizational group](#)).
- **Edit Group:** Modify an existing organizational group (see section 1.4: [Edit an organizational group](#)).
- **Add a person to a group:** Assign group memberships to a person (see section 1.5: [Add a person to an organizational group](#)).
- **Delete group:** Remove an existing group from the hierarchy (see section 1.6: [Delete an organizational group](#)).

**Note:** It is not possible to delete a person. People are linked to changes made to information in the application and such links cannot be broken.
1.1 Create a new person

Before a person is granted access to use goCASE, he or she must be added as a goCASE resource in the resource management component.

*Note: Creating such a person entry does not automatically give a person access to goCASE.*

To create a new person:

1. Select the **Person** tab. The person view is displayed.
2. Click on the button at the top of the Persons tab to create a new Person.
3. Add the mandatory information for the new person (fields marked with an asterisk are mandatory)
   
   i. **Functional title**: Select the person’s function from the drop-down list.
   ii. **First name / Family name**: Enter the name of the person into these fields.
   iii. **Display Name**: Enter the name to use as the person’s displayed name throughout the application.
   iv. **Home site**: Select the base office of this person from the drop-down list.
   v. **Display in resource selector**: Review if this person is to be displayed in the universal **Resource Selector** tool (see the goCASE User’s Guide for details).
4. Add as much optional information as possible.
   i. If you want to upload a photo: Click on Add Photo. The operating system’s file chooser appears. Else, right click on the photo and load, delete etc.
   
   ii. Select the desired image file. The photo is displayed in the image box.

5. Save the person information. The person record is created and the Group Membership input grid at the bottom of the screen is activated.

   ![Image of a form with options for adding a person]

6. Add the person to organizational groups (see section 1.5: Add a person to an organizational group for details).

   Note: The Account Status box will be empty until the person has been mapped to a goCASE user account.
1.2 Edit person

To edit an existing person in the resource management component:

1. Select the **Person** tab in the resource management. The person view will be displayed.
2. Select the person you want to edit in the **Person Resource List**:

3. Update the **Personal Details**.
4. Add the person to organizational groups (see section 1.5: [Add a person to an organizational group](#) for details).
5. **Save** the person information.
1.3 Create an organizational group

To add a new group/sub-group to the organizational structure:

1. Select the Groups tab in the resource management. The group view is displayed.
2. In the Groups List, navigate to the group under which you want to create the new sub-group, and right click on the group name.
3. Select (Add Sub Group).
4. An empty input form is displayed. To create a new root group, click on the ( ) at the top of the Groups tab.

5. Fill in the mandatory fields:
   
   i. **Organizational name**: Enter a unique name for the new organizational unit.
   
   ii. **Officer**: Click on “Browse” ( ).
   
   iii. Select the person responsible for the new group through the Resource Selector. (See the goCASE User’s Manual for handling details).
   
   iv. Fill in the optional fields where possible.

6. **Save** the new group. The group is created and added to the hierarchical structure in the Groups List

7. Add persons to the organizational group (see section 1.5: Add a person to an organizational group for details).
1.4  Edit an organizational group

To edit an existing group in the resource management component:

1. Select the Group tab. The group view is displayed.
2. Select the group you wish to edit in the Groups List:

   ![Group Management Screen](image)

3. Update the group details.
4. Add persons to the organizational group (see section 1.5: Add a person to an organizational group for details).
5. Save (✓) changes made.
1.5 Add a person to an organizational group

By default, people created in the resource management are not associated with the organizational structure and thus are not part of any group or department. New groups do not have any members except the group officer. To bring them together, you can either add a person to multiple groups or add multiple people to a group.

Add person to groups:

1. Select the Person tab. The person view is displayed.
2. Select the person you want to add/remove in the Person Resource List.

Assign the user to a group:

1. Click on “Append” (+) in the footer of the Group Membership grid. An empty row is appended.
2. Click on “Browse” ( ) in the Group Name field. The Resource Selector appears, showing the current group hierarchy.
3. Use it to assign the person to a group (see the goCASE User’s Manual for handling details).
4. Select the person’s actual Position in the group from the drop-down list.
5. Select the Start Date of the assignment and, if it is a temporary position, the End Date.
6. Repeat this procedure for every group the person is a member of.
7. Save ( ) the person information.
**Add persons to a group:**

1. Select the **Group** tab. The group view is displayed.
2. Select the group you want to edit in the **Groups List**:

![Group view screenshot](image)

3. Assign users to this group using the **Resource Selector** as described above.
4. Save (✓) the group information.

**Remove person from group:**

To remove a person from a group or groups:

1. Select the group and the person – in either the Person view or the **Groups** view.
2. Click on “Delete” (🗑️) in the footer of the **Group Members / Group Membership** grid.
3. After a security check, the person/group is removed.
1.6 Delete an organizational group

To delete an obsolete group from the organizational structure:

1. Select the **Group** tab in the resource management. The group view is displayed.
2. Select the group you want to delete and click on the (≡) at the top of the group tab.

*Note:* that you will need to remove all sub-groups and resources associated with this group before you can delete the group.

3. After a security check, the group is deleted.
2 Reference Tables

Many forms in goCASE contain drop-down lists. These lists offer a managed list of options to the user. In most cases, the System Administrator is responsible for managing these lists. For this, the Reference Tables module is provided.

Note: For details on the usage of drop-down lists, refer to the goCASE User’s Guide.

1. Select System Admin ▶ Reference Tables from the menu or the Reference Tables link in the Menu panel of the Startup tab. The reference tables maintenance form is loaded and displayed in a new tab:

The tab consists of two panels. The panel to the left shows a complete list of all goCASE reference tables, categorized in a tree structure. The right panel shows the details of the currently selected reference table (or is empty if a category is selected).

2. Expand (►) a category and select a reference table from the list. The table’s details are loaded and displayed:
The details are displayed in two panels: The top panel shows the currently available entries in this reference table in two different views, the bottom panel **Multi-Language Name** displays the currently selected entry’s information in all available languages.

3. Click on “Toggle view” ( ) to switch between the two different views.

**The fields view:**

This view shows the data arranged in individual fields:

4. Click on the different icons in the navigation bar (footer) to browse through the available options.

**Note:** The reference table data fields depend on the table definition. The fields shown above are the minimum and are part of all reference tables.

**The grid view:**

The grid view shows all entries with fields in a tabular structure:
### Reference Tables

<table>
<thead>
<tr>
<th>Identification Document Code</th>
<th>Identification Document Default Name</th>
<th>System Defined</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>BDC</td>
<td>Birth Certificate</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>DCC</td>
<td>Credit Card</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>ICL</td>
<td>International Driving License</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>ICC</td>
<td>Insurance Card</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>NDL</td>
<td>National Driving License</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>NID</td>
<td>National Identification Card</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>PPS</td>
<td>Passport</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>UNC</td>
<td>University Card</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>

### Available functions:

You can add new entries to a table (see section 2.1: [Add](#)), edit/translate the display value in the Default Name and Multi-Language Name (see section 2.2: [Edit reference table options](#)), or delete obsolete options (see section 2.3: [Delete reference table](#)).

**Note:** Once a user in goCASE has referenced a value it will no longer be possible to delete it. Start with the minimum values for a drop-down list and only add as needed to avoid unnecessary values, which cannot be removed later.
2.1 Add values to a reference table

To add a new entry to a reference table:

1. Select the table in the Reference Tables tree. The data for the table is displayed.
2. Choose a view (see section 2: Reference Tables) and add an entry as described below.

Add option in details view:

1. Switch to the details view.
2. Click on Append in the footer of the view. A new, empty value form is displayed:

   ![Value form](image)

3. Enter the values as follows:
   i. Enter the **Default Display Name** for the new entry. This is the name the user will see in the drop-down list.
   ii. Set **System-defined** to No
   iii. If the new option is not fully self-explanatory, add **Remarks**.

4. Save the option goCASE creates a unique **Code** and adds the entry to the list.

Add option in grid view:

1. Switch to the grid view.
2. Click on “Append” in the grid footer. A new empty row is appended to the list of options:

   ![Grid view](image)

3. Enter the values as described above. In most cases, goCASE will generate the code value automatically.
4. Save the entry. goCASE creates a unique Code and adds the entry to the drop-down list.

**Add the translation:**

The Default Name of an entry is displayed in the drop-down lists. However, it is possible to add translations for this entry. This is done in the panel Multi-Language Name.

**Note:** For newly created options, this grid is always empty.

1. Select the entry you wish to translate from the top panel. Click on “Append” in the footer of the Multi-Language Name grid. A new row is appended to the list of languages:

   ![Multi-Language Name Grid]

2. Add a translation as follows:
   
   i. Select one of the languages from the drop-down list Language.
   ii. Enter the translation of the entry into the field Name.
   iii. If necessary, add a Remark.

3. Repeat until you have added translations for all values.
4. Save the option.
2.2 Edit reference table options

To modify an existing reference table option:

1. Select the table in the Reference Tables tree. The current data for the table is loaded and displayed.
2. Select the entry you wish to modify in one of the view panels (see section 2: Reference Tables).
3. Edit the option’s fields and add translations as necessary (see section 2.1: Add for details).
4. Save the option.

2.3 Delete reference table values

To remove an obsolete entry from a reference table:

1. Select the table in the Reference Tables tree. The current data for the table is loaded and displayed.
2. Select the value you want to delete in one of the view panels (see section 2: Reference Tables).
3. Make sure there are no translations for this entry. If there are, delete them first. If System Defined is set to Yes, you will need to change it to No.
4. Click on “Delete” in the grid’s footer.

After a security check, the entry is deleted.

**Note:** If an entry has been referenced anywhere in the application it will not be possible to delete the entry.
3 System Administration

The system administration component of goCASE is a collection of modules to customize goCASE and for managing users and their access permissions. In detail, this covers:

**Localization:** Translate goCASE (see section 3.1: Localization).
**Objects:** Customizing case objects and their usage (see section 3.2: Case objects).
**Security:** Managing users, roles and their access permissions (see section 3.3: Security).
**Settings:** Various goCASE system settings (see section 3.4: Settings).
**Template maintenance:** Creating, updating, enabling and disabling any templates used throughout the system (see section 3.5: Template Maintenance).
**Workflow:** Setting up and customizing goCASE workflows (see section 3.6: Workflow).

3.1 Localization

While the default language for goCASE is English, it can be adapted to the culture and the language of the country using it. This implies that the software can not only be translated according to the linguistic conventions, but also be customized according to the cultural specifics of the users from the target country. A culture comprises both the language and other specifics common in a country. For every language, multiple cultures can be created (like en-GB and en-US for British and American English). To open the localization module:

1. Click on System administration (✎) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ➤ System Administration from the menu.
2. In the tree list in the left-hand panel, select Localization. The localization module is loaded and displayed in a new tab:
You can create a new culture (see section 3.1.1: [Create a new culture](#)), extract the user interface text resources (see section 3.1.2: [Extract All Translatable Text](#)) and translate the user interface texts (see section 3.1.3: [Translate goCASE](#)).

### 3.1.1 Create a new culture

The first step of a goCASE translation process is to create a new culture, which will hold the new language-specific strings and settings. In most cases, goCASE will already be set up to use your language preference:

**Note: To create a new culture, you must be logged in using the default English language.**

1. Update **Create Culture** in the goCASE localization module:

   ![Create Culture Module](image)

2. Select the culture to use as a template for your new culture in the **From Culture** drop-down list.
3. **From Culture** will only display cultures that have already been created in the application.
4. Select the desired To Culture from the drop-down list.

**Example:**
If you want to create Jamaican English, you will select [en] from From Culture and then select Jamaican English from To Culture. Click on Create Culture.

**Note:** Each culture can only be created once. However, you can always update an existing culture where necessary.

### 3.1.2 Extract All Translatable Text

Extraction is a technical background process for identifying all text strings in the application that can be translated. This includes buttons, labels, tool tips and more. goCASE takes care of this process automatically. Text extraction is used when creating a new culture as well as to generate all the new text strings after updating to a new version of the goCASE user interface.

1. During the extraction process, the grid will be updated with the currently available forms, controls and labels.
2. Once all text strings have been extracted, the application will close. You will need to log in again.

*Note: Depending on your computing power and database connection, extracting the goCASE strings can take several minutes. The process should not be interrupted. In the case of an interruption re-start the extraction process.*

### 3.1.3 Translate goCASE

To translate goCASE, you need to replace the labels, headings, tool tips and other display values in the Translation column with the translated word. By default, the Translation column is populated with the language used as the base for creating the new culture. There are two ways to translate the text. Either on the Localization form in System Administration else using the short-cut key F6 on any form in goCASE. The two processes work the same way.

*Note: To change your user language, refer to the goCASE User’s Guide.*

1. Login as the goCASE administrator.
2. Make sure that you have selected the language you wish to translate to as your preferred language in **User Preferences ➤ User Options**
3. Use the shortcut key F6 else the System Administration Localization form to view the translation options.
4. Translate the values in the Translation column to the new language. Save.
5. To search for a specific word, type the word at the top of the grid under Translation. This column holds the text that is currently displayed on the user interface.
6. When using the shortcut key the translations will immediately be visible in the User Interface. When using the Localization form in System Administration, the translations will be available the next time the user logs in.
3.2 Case objects

All the case objects used in the application are displayed in the Objects module of the system administration component. They can be customized if necessary. The following functions are available:

**Matching objects**: Adjust the rules for objects considered as “matching” (see section 3.2.1: Matching Objects).

**Enable / disable object types within a specific case type**: Define which object types are available in which case types and which ones are not (see section 3.2.2: Enable / disable objects by case type).

**Note**: You cannot create new object types through this customization. Contact the goCASE support team for any new object types.

3.2.1 Matching Objects

The matching objects module allows comparing new objects being created within a Case File or the Central Repository with already existing ones and shows possible matches. This helps avoiding duplicates in the database.

1. Click on “System administration” (CTRL) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ➤ System Administration from the menu.
2. In the tree list in the left-hand panel, select Objects ➤ Matching Objects. The matching objects module is loaded and displayed:

![Matching Objects Module](image)

Matching is determined by a percentage value. This percentage can be determined in the different case file objects based on data fields. While all case types have a default setting, you can adjust the settings as necessary.

3. Select the object type you want to edit the percentage for from the drop-down list Case Object. The object type’s current settings are displayed in the Object grid.
4. Activate (✓) the checkboxes in the column Enforce for the fields you want to use for the comparison.
5. Set the **Matching Rank %** by which you want to weigh this field for possible matches.

*Note*: The total for all activated columns may not exceed 100%. If you try to change the ranking for an already activated column, it will warn you that you are trying to enter an invalid value. The system will also not allow you to activate a column which will push the total ranking above 100%.

6. The **Comparison Type** column has options based on the type of column selected.

   (Any) = The text being compared must be exactly the same
   (String) like The existing entry in the database must contact the text being compared
   (String) Left(3) The left 3 characters for the string must be the same
   (Numeric) <> The value must be larger or smaller than the already existing value
   (Date) Matching The new value matches an existing entries year.

   **Example:**
   In the above screenshot, an authority with the same Full Name and Contact Person would have a matching probability value of 100%.

7. Save (保存) the changes.

*Note*: The matching percentage can never exceed 100%.

### 3.2.2 Enable / disable objects by case type

You can decide which types of objects appear in which case types:

1. Click on System administration (系统管理) in the toolbar, on the **System Administration** link in the **Menu** panel of the **Startup** tab or select **System Admin ▶ System Administration** from the menu.
2. In the tree list in the left-hand panel, select **Objects ▶ Objects**. The objects module is loaded and displayed in a new tab:
3. Select the type of object you wish to customize in the top grid of the Object panel. The middle grid displays the Case Types where this object has been activated.

4. To add the object type to a different case type, click on (+) at the bottom of the middle grid. A new row is added to the grid. Now select the Case Type you wish to add the Object Type to. Note that it will only allow you to add a Case Type that is not already in the list.

5. To remove an Object Type from a Case Type, select the Case Type in the middle grid and click on “Delete” (−)

6. Save (✓) the changes.

**Note:** The bottom grid shows the different case types (columns) and the number of objects per object type in each of them (in brackets).
3.3 Security

The security module manages the following security aspects of goCASE:

- User logins and group memberships (see section 3.3.1: User Maintenance).
- Roles and their permissions (see section 3.3.2: Role maintenance).
- Report permissions and global disabling of reports (see section 3.3.3: Report Maintenance).
- Screen permissions (see section 3.3.4: Screen maintenance).

3.3.1 User Maintenance

The user maintenance module of goCASE is responsible for handling the user accounts. User Maintenance manages the users who have access to the goCASE application. Any person wishing to use goCASE must be registered as a user and granted applicable permissions.

1. Click on System administration ( ) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ▶ System Administration from the menu.
2. In the tree list in the left-hand panel, select Security ▶ Users. The user maintenance module is loaded and displayed:

3. The Users List shows a list of all currently available user accounts together with the names of the users and the date of the last activity and indicates if they accounts are enabled (✓) or disabled ( ).
4. The User Details panel shows the data of the user currently selected in the users list.

Create a user:

Note: As a prerequisite for creating a user account, a matching resource person must have been created first (see section 1.1: Create a new person).
1. Click on Append (+) in the bottom of the Users List. An empty row is appended and an input form is displayed:

2. Enter the user information into the fields of the Profile tab:
   i. Define a unique User ID. Please take care when defining a User ID as once this has been saved it cannot be changed or deleted.
   ii. Click on Browse (△) in the Resource Person field. The Resource Selector is displayed. Use it to select the person behind the new user account.

   *Note:* Only one user account may be mapped to one person and vice versa. See the goCASE User’s Guide for details on the Resource Selector and its usage.

   iii. Add the initial password of the user account into the fields Password and Confirm Password.
   iv. Activate the checkbox Account enabled if you want the user account to be ready-to-use right after creation; deactivate it if you want to keep it inactive for the time being and make it available later.
   v. Select the date from which the account shall be valid in the field Enabled Date.
   vi. Activate the checkbox Account never expires to make the account permanent or deactivate it and select an Expire date.
   vii. Save (✓) the account.

   *Note:* You can edit existing user accounts at any time by selecting the user in the users list and applying the necessary changes; however, you cannot change the User ID.

**Role Membership**

Access to forms and reports in goCASE are managed by the Role the user belongs to. In order to grant access to these forms and reports, the user has to be assigned to a Role. A user can be assigned to as many roles as are available in the system. Each role grants specific permissions for the system (see section 3.3.2: Role maintenance for details).

1. Switch to the tab Role Membership:
Add a role to the user account as follows:

i. Click on Append (+) in the footer of the grid. A new, empty row is appended.
ii. Select the appropriate **Role** from the drop-down list.
iii. Activate the checkbox **Enabled** if you want the role to apply to the user account; deactivate it to keep the role membership dormant.
iv. Select the start date for this role being available in the field **Date Enabled**.
v. Activate **Expires** if you want this role to be temporarily available and select an **Expire Date**; deactivate this checkbox to assign the role permanently. Save (✓)

**Screens / Reports:**

These two tabs in the user maintenance module show the current permission details for the selected user based on the user’s Role Membership.

**Note:** These tabs are for your information only. You cannot change anything in them.
User Settings:

This setting is used to allow a user to change their originating site when creating a new Case File. By default, a Case File’s originating site is set based on the person’s Home Site set in the Resource Management module. In the case where a user moves between regional offices and Head Office, it might be necessary for them to be able to change the originating site of their Case Files.

Note: For details on creating new Case Files, refer to the goCASE User’s Guide.

3.3.2 Role maintenance

The role maintenance module is where the permissions are set up for users. A role is a set of permissions for the goCASE application. A user can be mapped to as many roles as are available in the system; his total access rights are the sum of his roles.

1. Click on System administration (🔗) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ▶ System Administration from the menu.
2. In the tree list in the left-hand panel, select Security ▶ Roles. The role maintenance module is loaded and displayed:

The Roles List shows a list of all currently available user roles and indicates if they are currently enabled (✔️) or put out of service ( onCancelled), are permanently active (✓) or expire (_expiry_date). The Profile panel shows the data of the role currently selected in the roles list.

Create Role:

1. Click on Append (+) in the bottom of the Roles List. An empty row is appended and an input form is displayed:
2. Enter the user information into the fields of the **Profile** tab:

![Profile tab](image)

i. Define a unique **Role Code** (3–12 characters) and **Role Name** (mandatory).
ii. If necessary, add a **Remark**.
iii. If you want the role to be available, activate (✓) **Role enabled** and select the date from which it shall be active in the field **Enabled Date**.
iv. Activate **Role expires** and select an **Expire date** if you want the new role to be a temporary one.
v. Activate **Supports Super User** to allow users having this role to be “super users”.

*Note: Super users are the selected users who have full access to all goCASE case files regardless of the Case File Security setting. A Super User needs to belong to a Role that supports Super Users. The user also needs to be activated as a super user on the specific user’s user profile tab.*

2. **Save (✓)** the role.

*Note: You can edit existing roles at any time by selecting the role in the roles list and applying the necessary changes; however, you cannot change the role code.*

**Role Members:**

In order to grant permission to a user to access specific forms and reports, users are assigned to roles managing the access rights. A role can be assigned to multiple users (see section 3.3.1: [User Maintenance](#) for details).

1. **Switch to the tab **Role Members**:**
Add users to the role as follows:

i. Click on Append (➕) in the footer of the grid. A new, empty row is added.

ii. Click on Browse (🔍) in the User column to select the desired user

   Note: See the goCASE User’s Guide for details on the Resource Selector and its usage.

iii. Activate the checkbox Enabled if you want the role to be available immediately for the user; deactivate it to keep it inactive for the time being.

iv. Select the start date for this role being available to the user in the field Enabled Date.

v. Activate Expires if you want this role to be temporarily available for the user and select an Expire Date; deactivate this checkbox to assign the role permanently.

vi. Save (✔) the role.

Screens:

Each role grants access to the different screens of the goCASE application. These can be set in the Screens tab.

1. Switch to the tab Screens

2. Activate (✔) the checkboxes of the permissions you want to give to that role; deactivate (🔴) the others. As a rule, the Workflow Maintenance and System
Administration screens are only activated for the Role governing the goCASE System Administrators.

3. Save (✓) the role.

**Note:** As a prerequisite for insert/update or delete permissions, the role must have select permissions.

**Reports**

As with the application’s screens, there are individual permissions for the different goCASE reports available.

1. Switch to the tab **Reports**

2. Select the **Report Category**; the report panel displays all reports in this category

3. In the **Role Reports** grid, you can see which of these reports are active for the selected role and what the permission details are.

4. Adjust the reports permissions as follows:
   i. Add another report to the Role Reports by double-clicking it in the **Reports** tab.
   ii. Activate (✓) the checkboxes of the permissions you want to give for that report; deactivate (☐) the others.
   iii. To remove a report from the role, select the report in the Role Reports grid and click on Delete (🗑️) in the grid’s footer.
   iv. Click on “Add all reports” (✓) to add all the reports for the selected Report Category.
   v. Save (✓) the role.

**3.3.3 Report Maintenance**

The report maintenance module allows managing the available goCASE reports: You can enable or disable reports for all users, translate the report names and descriptions and activate or deactivate certain report functions.

1. Click on System administration (♭) in the toolbar, on the **System Administration** link in the **Menu** panel of the **Startup** tab or select **System Admin ➤ System Administration** from the menu.
2. In the tree list in the left-hand panel, select **Security ▶ Reports**. The report maintenance module is loaded and displayed:

3. The tab is divided into different panels. **Report Categories** shows the available categories, **Reports** displays the reports in the selected category together with their settings, **Report Language** lists the description of the selected report in the different goCASE languages and **Report Access Control List** displays the user roles having access to the selected report and the detailed access permissions.

**Edit basic settings:**

To modify the basic settings of a report:

1. Select the **Report Category**. The available reports are displayed in the **Reports** grid.
2. Activate (✓) the checkbox **Display in Report List** to make this report available for users; deactivate (☐) it to hide the report completely. This does not affect the security settings. If a report is made active, it will still need to be included in a Role before it will be active for the users.
3. Activate the checkbox **Apply Case Security** to make the report sensitive to the case security settings (refer to the goCASE User’s Guide for case security details), deactivate it to ignore them. If a report is set to ignore Case Security, all case files will be shown in the report results list regardless of the User’s access to that Case File.
Translate Report Name and Description:

The description of a report can be translated to comply with the overall application language:

1. Select the **Report Category** and the desired report in the **Reports** grid. The available translations are displayed in the **Report Language** grid.
2. Edit an existing translation by clicking into the fields and replacing the text.
3. Create a new translation as follows:
   i. Click on Append (➕) in the footer of the grid. A new, empty row is appended to the list.
   ii. Select the **Language** from the drop-down list.
   iii. Enter your translations into the fields **Report Name** and **Report Descriptions**. The Report Name is the name of the report as it appears in the list of reports available. The Report Description describes the content of the report and is available to the user when they click on the question mark in the top right corner of any report.
4. Save (حفظ) the report.

Report Access Control:

The **Report Access Control List** shows which roles are permitted to view the selected report and which particular actions are allowed.

1. Select the **Report Category** the report belongs to and the report in the **Reports** grid. The current groups and their permissions are displayed in the **Report Access Control List** grid.
2. Activate (✓) the checkboxes of the permissions you want to allow for that report; deactivate (✗) the others.
3. Save (حفظ) the report.

3.3.4 Screen maintenance

The screen maintenance module displays all currently available goCASE screens (i.e. functional tabs) for your information.

1. Click on System administration (إدارة) in the toolbar, on the **System Administration** link in the **Menu** panel of the **Startup** tab or select **System Administration ▶ System Administration** from the menu.
2. In the tree list in the left-hand panel, select **Security ▶ Screens**. The screens list is loaded and displayed:
Note: This module is for your information only. No actions are possible in the current goCASE version.
3.4 Settings

Settings, is a collection of customizable features in goCASE. Use them to configure the application to your needs. The settings are divided into Application Settings (see section 3.4.1: Application settings), Audit settings (see section 3.4.2: Audit) and Case Numbering settings (see section 3.4.3: Custom numbering settings).

3.4.1 Application settings

The application settings page combines all variable basic features and attributes that are used in goCASE.

1. Click on System administration (洙) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ➤ System Administration from the menu.
2. In the tree list in the left-hand panel, select Settings ➤ Application Settings. The settings are loaded and displayed.
3. Apply the necessary changes to the fields (see below).
4. Save (洙) the changes.
The settings:

The following settings are available:

**Site ID:** The official name of the site using this goCASE installation.

**Central repository CIN:** The case identification number of the central repository. Internally, the repository is treated as a special case type so it needs a CIN.

*Note: This must only be changed by the goCASE Support Team.* (See the goCASE User’s manual for repository details).

**Default security level code:** When a new Case File is created, it will by default use this setting to set the initial Case File Access level. (see the goCASE User’s manual for Case File Security)

**DB mail enabled / DB mail profile:** If DB mail is enabled (“Yes”), then goCASE messages are not only sent to the goCASE message board and To-Do list, but also to the email address of the recipient. The profile is the name of the sender. For this to work, the mail functionality needs to be activated in the SQL server. This needs to be set up with help from the goCASE Support Team.

**Check for duplicate objects:** The Matching Objects functionality is used (“Yes”) or not (see section 3.2.1: Matching Objects).

**Closed Cases Editable by Super User:** By default, Case Files are not editable once they have been closed in the workflow. This setting allows the Super User to edit closed Case Files

**Notify Reporting Officer of case security changes:** When the security level of a Case File is changed, the Reporting Officer of the person changing the security level will be notified via a message in the message board. Make sure that the Reporting Officer has been set for each resource in the Resource Management module.

**Allow the Case Officer to overrule the workflow execution in the Case File:** When a Case File has been forwarded to a person using the workflow, the receiving person is responsible for the Case File and needs to move the Case File to the next step. When this check box is checked, the Case Officer can forward the Case File on behalf of the responsible user.

**Allow users to change their originating site:** By default, the originating site or a new Case File is based on the person’s Home Site as set in the Resource Management module. This setting will allow the user to change his or her originating site. This must also be activated on the user settings in the System Administrator.

**Organization:** The official Name of your organization and its Code, the CIN Prefix code and a logo Image. The information provided here is used in printable reports. The CIN Prefix cod is used as the first 3 characters of the Case File Numbers.

**Default case type code:** The type that is used as the default option in case type selection fields. It can be changed by the users when they create case files.

**Default trigger code:** The type, which is used as the default option in trigger type selection fields. This can be changed by the users when they create case files.

**Default originating site ID / Department code:** The static part of any new case identification number (CIN). This is the default for a site but depends on where a user is registered.

**Default country:** The country that is used as the default option in country selection fields.

**Default language / Default culture:** The language/culture the application starts with. This applies for all new users and can be changed by the users individually later.

**Default currency:** The currency that is used as the default option in country selection fields.
Load Notes max no.: The maximum number of notes displayed in the Startup tab for new users.

Load message board max days: The maximum number of days of messages shown in the Startup tab’s message board.

POI Max Number: This is currently not in use.

Max no. of last accessed cases: The maximum number of cases shown in the Startup tab’s case file browser.

Refresh interval: The interval (in minutes) when goCASE checks for new messages and notes.

Log stored procedure call: Internal goCASE procedure calls are logged in the system (“Yes”) or not (“No”).

Archive deleted records: Deleted goCASE records (persons, accounts etc.) are not completely discarded but moved to an archive table in the database.

Server: The servers and database names for the available goCASE databases

Regional offices: A list of all offices of your organization

### 3.4.2 Audit

The audit shows an overview of all system procedures goCASE uses and indicates if the stored procedures are being audited. All procedures logged by goCASE are shown as “Yes” in Log Procedure Run.

1. Click on System administration (⌘) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ➤ System Administration from the menu.

2. In the tree list in the left-hand panel, select Settings ➤ Audit. The procedures list is loaded and displayed
Note: This is for information only and cannot be changed.

3.4.3 Custom numbering settings

The Custom Numbering module provides a way to create a custom number for all Case Files and is inserted into the Internal Case Reference. This number is in addition to the CIN and is editable by the case users. This number can consist of fixed text as prefix and/or suffix, sequence numbers, dates and separators. However, it must at least have one sequence value that is automatically increased for every new case. The actual structure is defined in the custom numbering settings.

1. Click on System administration (🔗) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ▶ System Administration from the menu.
2. In the tree list in the left-hand panel, select Settings ▶ Custom Numbering. The numbering module is loaded and displayed.
3. Click on (¶) ”Add” next to the Template drop-down. Select the case type you want to customize the numbering for in the Template drop-down, and give the case numbering profile a code name.

4. Define the numbering parameters as follows:

   i. **Separators**: These are the separators used to break up the number i.e. between a prefix and a date or prefix and a sequential number. The number can have up to 4 different separators.

   ii. **Fixed Text**: This is where you can set the Prefix and/or Suffix to distinguish easily between the different case types (optional but recommended).

   iii. **Sequence**: This is the sequential number within the customised number. This is to ensure that every reference number is unique. The Step is the increment between two consecutive case numbers. By default, this is set to 1. The No. of Digits indicates how many digits in the sequential number with Leading Character being the placeholder if the number is not long enough to fill the No. of Digits. E.g. if your sequential number is 21 but the No. of Digits has been set to 5 and the Leading Character is 0 the sequential number will be displayed as 00021. Define the intervals in which the numbering should be reset to 0.

   iv. **Date Format**: If you incorporate the date into the number, decide which Year format and Month format you want to use.

5. To set the sequence of the number’s elements, drag-and-drop the columns in the **Custom number structure** into the desired order. To add or remove columns, use the **Column Chooser** by right clicking on the structure column list. (See the goCASE User’s Guide for details).

6. A sample of what the number will look like is displayed in the sample input under the Column number structure.
7. Set **Apply numbering** to “Yes”, if you want to create the editable Internal Case Reference Number for customer-specific numbering in addition to the goCASE-specific case identification number (CIN).

8. Save (✓) the settings.
3.5 Template Maintenance

The template maintenance module is the goCASE focal point for creating, updating and disabling any templates used throughout the system. A fixed set of ready-to-use templates comes with the goCASE installation, but you can always create your own templates if necessary.

1. Click on System administration (🔒) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin ➤ System Administration from the menu.
2. In the tree list in the left-hand panel, select Template Maintenance. The template maintenance module is loaded and displayed.

3. All available templates are shown, together with their names and whether they are public (✔️) or hidden (☐). The following functions are available:

Create template: Add a new template to the list (see section 3.5.1: Create a Template).
Edit template: Modify the metadata or the contents of a template (see section 3.5.2: Edit Template).
Delete template: Remove an existing template (see section 3.5.3: Delete Template).

3.5.1 Create a Template

To create a new template for goCASE in the template maintenance module

1. Click on Append (➕) in the footer of the panel. A new card is added to the panel.
2. Enter a (unique) Name and decide if you want to make the template Public (✔️) from the very beginning or keep this step for later.
3. Under form type, select the case object type the template is being designed for. To use the template, right click on an object of the same type in a case file. The template will appear under the associated forms menu.
4. Double-click the report card. The Report Designer is displayed.
5. Use the walkthrough in Annexure A to create a template:
3.5.2 Edit Template

To edit an existing goCASE template:

1. Double-click the template in the template maintenance module. The Report Designer is loaded and displayed.

2. Use the walk-through in the Annexure below to see how to edit the template.

*Note:* It is possible to map data fields from the goCASE database directly into a template so that for instance when opening the template for a person, all associated fields for this person will already be filled in.

3.5.3 Delete Template

To delete a template from the goCASE database:

1. Select the template in the template maintenance module (see section 3.5: Template Maintenance)
2. Click on “Delete” (≠) in the footer of the panel.
3. After a security check, the template is deleted.
3.6 Workflow

Productive work in goCASE is based on workflows. These workflows are set up by the goCASE administrator before any case files can be created. A case type will have a workflow attached to it. One workflow can be used in multiple case types but a case type can only be associated to one workflow.

1. Click on System administration (⌘) in the toolbar, on the System Administration link in the Menu panel of the Startup tab or select System Admin  System Administration from the menu.
2. In the tree list in the left-hand panel, select Workflow. The workflow maintenance module is loaded and displayed:

Workflow list: The left-hand panel shows a list of all workflows in the goCASE database. Select one to display its details on the right side of the screen.
Workflow Diagram: The graphic representation of the workflow.
Business Cycle Details: The name and description of the workflow.
Transitions: The technical and business details of the workflow:

**Transitions – Regular Flow:** Shows the sequence of transitions from start to end of the regular flow.

**Transitions – Optional Flow:** Shows the optional steps available in the workflow cycle.

**Transition details:** Lists the details of the currently selected transition, both from the regular or the optional flow.

**Transition Optional Flow:** Shows the different options available if you do not follow the currently selected regular or optional workflow business cycle.

**Transition Execution – Roles:** Allows adding roles to the selected transition in the workflow. All users belonging to this role automatically get the right to execute this transition.

**Transition Execution – Users:** Allows adding individual users to the transition in addition to the roles.
Functions:

1. Select a workflow name in the left-hand panel to load and display the details of the workflow.
2. Click on Hide Panel at the top of the left panel to hide the list of workflows and on Show Panel to display it again.

Setting up a goCASE workflow in done in six consecutive steps:

Create a workflow business cycle
Create regular flow transitions
Create optional flow transitions
Add optional transitions to regular transitions
Assign roles and users
Assign workflow to case type

3.6.1 Create Workflow Business Cycle

The business cycle defines the type of workflow. For instance, there could be one workflow to manage Investigation Case Files and one workflow to manage Intelligence Case Files. This function allows creating, deleting and editing workflows. To add a workflow:

1. Click on the Append button (▼) at the top of the workflows list. An empty Business Cycle is created and the Business Cycle Details screen is displayed:

   ![Workflow Diagram](image)

   - Cycle Code: 00001
   - Name: NBIP Investigation Cycle
   - Description: NBIP Investigation Cycle
   - Backward Iteration: No

2. Fill in a (unique) Name for the workflow and an informative Description.
3. Select if you want to allow Backward Iteration (allowing the user to return to a previous step in the workflow) or not. All these values except the Cycle Code can be changed at a later stage.
4. Save the new workflow.

3.6.2 Create Regular Flow Transitions

The transitions are the succession of steps in the workflow. They are either regular (the default succession of steps) or optional (digressions). To create transitions or edit transitions for a specific workflow:
1. Select the workflow from the list and switch to the **Transitions** tab. Both the regular and the optional transitions are shown in this tab:

<table>
<thead>
<tr>
<th>Trans. Code</th>
<th>Name</th>
<th>Action</th>
<th>Status</th>
<th>Next</th>
</tr>
</thead>
<tbody>
<tr>
<td>0001-001</td>
<td>Draft</td>
<td>Submit For Instructions</td>
<td>Start</td>
<td>Pending Operations Action</td>
</tr>
<tr>
<td>0001-002</td>
<td>Pending Instructions</td>
<td>Approve and Forward to...</td>
<td>Intermediate</td>
<td>Pending Operations Action</td>
</tr>
<tr>
<td>0001-003</td>
<td>Pending Operations Action</td>
<td>Assign to Specialized Unit</td>
<td>Intermediate</td>
<td>Assigned to Specialized Unit</td>
</tr>
<tr>
<td>0001-004</td>
<td>Assigned to Specialized Unit</td>
<td>Assign to Handling Team</td>
<td>Intermediate</td>
<td>Assigned to Handling Team</td>
</tr>
<tr>
<td>0001-005</td>
<td>Assigned to Handling Team</td>
<td>Set Under Investigation</td>
<td>Intermediate</td>
<td>Under Investigation</td>
</tr>
<tr>
<td>0001-006</td>
<td>Under Investigation</td>
<td>Set Investigation Final Status</td>
<td>Intermediate</td>
<td>Investigation Final Status</td>
</tr>
<tr>
<td>0001-007</td>
<td>Investigation Final Status</td>
<td>Investigation Final Status</td>
<td>Intermediate</td>
<td>SERMSA</td>
</tr>
<tr>
<td>0001-014</td>
<td>SERMSA</td>
<td>TEST</td>
<td>End</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** In the case of a new workflow, the transition grids are empty.

2. To add a regular flow transition click on the Append icon (++) in the footer of the **Transitions - Regular Flow** section. An empty Transition Detail panel is provided in the sidebar:

![Transition Details Panel]

3. Enter the details into the data fields (see below).
4. Save (✓) the transition. The transition is added to the workflow.
5. Select the new transition in the **Transitions - Regular Flow** section and move it to its place in the workflow using the Move selected transition up (✓) and Move selected transition down (✓) arrow icons. The **Status** of the first step in the workflow will always be “Start”, the one of the last step “End” (all others “Intermediate”)

---

Page 48 of 63
6. **Alerts**: Here a time limit can be set on the selected transition. If a time limit is set for 1 day, the user will start getting notifications in their Message Box to say that the time limit has expired.

7. **Commands**: Here it is possible to instruct the system to set the Case First Officer and Case Second Officer for a Case File. It is also possible to add a person to the Case Access Control with full access. The Case Officers for the case file can always change security.

**The data fields:**

- **Name**: A short but descriptive name for the transition. This will show the current status of a case file throughout the application.
- **Action**: The text that will be displayed to the user on the action button in the workflow control on a case file.
- **Start end**: Indicates whether this is a start, intermediate or end transition of the business cycle.
- **Next Trans**: Automatically filled with the next transition step as seen in the Transitions - Regular Flow section.
- **Description**: A description of the transition.
- **Message to receiver**: This is the message the current owner of the Case File will receive when the Case File is forwarded to them from the previous responsible person. Messages are shown on the message board in the Startup screen.
- **Message type**: Select Message or Task as the type of message for the recipient (see the goCASE User’s Guide for details).
- **Cmnts mandatory**: Select “Yes” or “No” from the drop-down list to indicate whether the user is required to add a comment before forwarding the Case File to the next responsible person. Changing this will affect the currently selected transition.
- **Transition enabled**: If it is “Yes” (default), then the transition step is part of the actual workflow; if it is “No”, then the step will be skipped.
- **Flow type**: Select “Regular Flow” or “Optional Flow” transition.
- **Associated form**: Select the goCASE system form that will be opened when the user double-clicks on a message received in the “Workflow Assignments” screen (mandatory). Unless instructed otherwise by the goCASE support group, this will always be Case File.
- **Pre-requisite form**: Some steps require filling in external documents or forms. Select them here. This is done in conjunction with the goCASE support group.

### 3.6.3 Create Optional Flow Transitions

Once all the regular transitions have been created, define the optional flow transitions. These are transition variants that can be assigned to specific transitions steps. A typical example would be setting a case to dormant at some stage in an investigation, instead of pursuing it further.

1. Select the workflow from the list and switch to the **Transitions** tab.
2. To add an optional flow transition click on the Append icon (⊕) in the footer of the Transitions - Optional Flow section.
3. Proceed as described for regular flows in section 3.6.2: Create Regular Flow Transitions.
3.6.4 Add Optional Transitions to Regular Transitions

When all regular and optional transitions of the business workflow cycle have been defined, you have to determine, where in the flow the optional transitions come into play.

1. Select the regular transition where an optional flow variant needs to be added in the panel Transitions - Regular Flow. The panel Optional Transition shows all current optional transitions pointing out of the selected transition (or is empty, if there are none).

2. It is possible to add a regular transition as an optional transition. Using the example in the diagram above, when a case has been in the status Under Surveillance, and the outcome was that the surveillance team was exposed; the Case File needs to be assigned to a different team. Using the option of sending the Case File back to Pending Approval so that it will be assigned to a different team, would be a regular flow being used as an optional flow.

To add a new optional or regular transition:

i. Click on the Append icon (⁺) in the footer of the panel. A new, empty row is appended.

ii. Select the transition step you want to point the optional flow to from the drop-down list.

Example:
If the selected transition step is “Information received” and the next regular step is “Analysis complete”, then you could add an optional intermediate step “Collect more data”. This gives the analyst the chance to interrupt the process for acquiring more information about the matter before the analysis is completed.

3.6.5 Assign Roles and Users

A user who wants to forward a case to the next step in the workflow needs permissions to do so. For each transition step, the responsible user roles have to be defined. Furthermore, single users, who do not belong to the selected role/s, can also be added to the step and thus entitled to process it:

1. Select the step you want to assign roles to in the panel Transitions - Regular Flow or Transitions - Optional Flow respectively.

2. The panel Transition Execution shows all currently entitled roles (in the tab Roles) and individual users (in the tab Resource) of the panel (or is empty, if there are none):
To add a new user role to the step:

i. Activate the tab Roles.

ii. Click on the Append icon (†) in the footer of the panel. A new, empty row is appended.

iii. Select a role from the drop-down list Roles.

To add a new resource (user or group) to the step:

iv. Activate the tab Resource.

v. Click on the Append icon (†) in the footer of the panel. The goCASE Resource Selector is displayed.

vi. Use it to select the desired users and groups (see the goCASE User’s Guide for handling details).

3. Repeat the procedure until all steps are equipped with at least one resource or role.

4. Save (✓) the workflow.

3.6.6 Assign Workflow to Case Type

To be able to use a workflow in a specific case type, it has to be assigned to this case type:

1. Select System Admin ▶ Reference Tables from the menu. The reference tables’ maintenance function is loaded and displayed in a new tab.

2. Select System Data ▶ Case Type. The case type panel is displayed:

3. Browse (❖) through the case types for the type you want to assign your workflow to or click on “Toggle view” (❖) and select the case type in the grid:
4. Select your workflow from the drop-down list **Workflow cycle**.
5. Save (保存) the settings.
4 Annexure A:

4.1 Create a Template Walkthrough

4.1.1 Add the default application image to the top of the template:

1. Drag a Picture Box from the left panel into the centre of the ReportHeaderBand.

2. Make it the size you want and using the two buttons at the top to centre it.

3. To add the application default image (as shown in the centre of the goCASE Startup screen) - click on Scripts at the bottom

4. Make sure that the pictureBox is selected from the top left drop-down box, and from to the top right drop-down, select before Print.

5. It automatically inserts code on the screen. In-between the {} add the following lines (by default the cursor will be positioned between the brackets): Make sure the name for the picture box in the code is the same as the name of your picture box. (In this case pictureBox1)

   ```csharp
   this.pictureBox1.Image = goCaseLIB.Common.FileSystem.byteArrayToImage(goCaseLIB.Common.Properties.OrganizationLogo);
   this.pictureBox1.Sizing = ImageSizeMode.Squeeze;
   ```

6. Click Save and then click Designer again at the bottom of the screen

4.1.2 Add Any image to the top of the template:

1. Repeat step 1 in the step above.
2. Make sure your picturebox is selected. Now on the property Grid on the right, select

![Property Grid]

Image and select the image you wish to Insert.

4.1.3 Add a heading to the report

1. From the left side panel, drag a label to the **ReportHeaderBand** and put it below the image or wherever you want the header to be.

2. In the Property Grid on the right, Rename the label to **lblReportHeader**. If the property grid is not visible in the right panel, right click on the form and select [Properties] from the bottom of the menu.

![Property Grid]

3. Change the Text property to the text you want to have as a header. In this case we are putting in a fixed header. **Authorities**. Change the Text Alignment, Font etc. to display the way you want it displayed.
4.1.4 Adding Detail to your report:

In this example we are going to replicate what is on the Authorities object. From the left side drag a label to the detailBand and rename it to lblCompetentAuthority.

1. Change the text in the Property Grid to **Is Competent Authority**: Make sure the label box is large enough. Change the text alignment, font etc. (This can also be done once all the labels have been added) Now, add the rest of the labels.

2. To re-size any label hover over the blue squares and when your cursor changes to a double sided arrow, click and drag to the desired size.

3. To make more space, drag the reportFooterBand1 down.

4. Once all the labels have been added, we need to add the details. From the [Field List] on the right expand the tables to find the one with the details you wish to use.
5. Drag Competent Authority and drop it next to the label [Is Competent Authority].
   Do the same for the other fields.

6. Now resize the fields so that they are large enough to show the details.

   *Note: Description of Services and Remarks should both allow for more data.*

7. In both these boxes, select the box, and in the Property Grid on the right, change the value for Multiline to [Yes]. Now select the label and the field at the same time and in the Property Grid, change Keep Together to [Yes].
Note: Both need to be selected together. Remember to save regularly.

We have now added the free text part. You can test this by right clicking on an Authority in a case file and loading the document. Text by adding a large Description of Services block of text to make sure everything aligns correctly.

4.1.5 Now to add the contact details:

Contact details could have multiple rows. For this we need to add a detail report.

1. Right-click on the detailBand and select Insert Detail Report.

2. We want to add a header to this so right click on DetailReport and select Insert Band ➔ Report Header

3. Now drag a label into the ReportHeader section and change the text to Address.

4. In The Detail section add labels for the different Address Fields. Remember to set the longer fields to multiline etc. Once you have added all the fields for an address you might want to add a line to separate the addresses if there is more than one address.

5. Drag the line from the left side and put it at the bottom.
6. Now click on the **[Detail]** bank and change **Keep Together** to **[Yes]** in the Property Grid. This will just ensure that your address is not split over two pages.

7. Before we test this you need to indicate that it is a possible multi entry report. On the **[DetailReport]** band, click the little arrow to open the screen below (See image below).

8. On the **Data Member** select the table where you dragged the data fields from. This will tell the report to print all the values relating to the address. If you don't do this it will only print the first address in the list.
9. You can also prevent the document from printing this section if there are no addresses. Click on the [Detail Report] band, then on the Property panel to the right, expand Report Print Options. Now change Print when Data Source Empty to No.

4.1.6 Now add the Phone numbers the same way


2. Right-click on the new band and insert a ReportHeader.

3. Add the labels and fields and set the Data Member

4.1.7 Now to add the grid for Communication Other:

1. Once again right click on the [detailBand1] and insert a detailed report.

2. Right-click on the new band and insert a Report Header.

3. Right-click on the new band again and also insert a Group Header.
4. In the Report Header add a label as above and change the text to Communication Other.

5. Now, we want to add a table with the details. From the left side panel, drag a table into the GroupHeader section. This table is going to hold our column headers. We will have 3 columns: Communication Type, Communication Information and Remarks.

![Diagram of GroupHeader table]

6. Change the text in each one of the columns to the header for that column then space the columns the way you want them. Also move up the Detail2 band to be flush with the header table.

![Diagram of GroupHeader table with text changes]

7. Now drag a second table into the Detail2 Section and space the columns to be the same size as the table above. Drag the report footer band up to be flush with the bottom of the table.

![Diagram of Detailed report table]

8. Next we need to drag the fields from the field list in the left panel, and drop them into the relevant columns in the bottom grid.

9. Set the Data Member for the Detailed report.
4.1.8 Now we would like to add a footer.

1. Drag the Page Info control onto the **pageFooterBand**. We want to add the current date to the footer of all the pages.

2. Expand by clicking the arrow at the top of the Page Info control. Change Page Info to Current Date and Time. This will automatically add the current date and time to the bottom of all the pages. You can change the format by clicking on the Format expansion and selecting date.

3. To add the current user to the report and a label to the report and change the label name to **lblUser**.

4. Now click on the Scripts tab at the bottom of the form. Make sure **lblUser** is selected at the top left and select Before Print from the right hand side drop down. This automatically adds lines to your script. Between the {} add the following.

   ```csharp
   this.lblUser.Text = goCASE.utils.global.UserDisplayName;
   ```

4.1.9 Things to check if you cannot see your template in the case file:

Has it been marked as Active in the System Administration?

4.1.10 Other

Formatting a date.

1. Click on the date field/label to be formatted. Now, on the arrow at the top right corner.
2. Click on the Format String button, select DateTime and select the type of formatting. Number can be formatted the same way.

4.1.10.1 Changing the template to landscape:

1. In The Property Grid at the right, select [XtraReport Report] from the drop down box at the top.

2. Now, go and change the Landscape option to [Yes]

3. If you are trying to display data which has formatting you can use the Rich text control instead of the textbox. It is also possible to combine text and fields using this control. As an example. Drag the rich textbox onto the form. Now type the text you wish to display around your field. E.g.
Note: [City Name] and [Date of Offence] are in square brackets.

4. Now drag the required field onto the text to be replaced. You will notice the text is highlighted just before you drop the field into position

This offence took place in City Beta on the 13/03/2013 00:00:00